[SOLVED] No valid license available in your Qt Account for this host platform. Win10.



  • I updated Qt maintenance tool and it asked for my Qt account credentials. A entered them and now it writes No valid license available in your Qt Account for this host platform. Wtf? I always used free OSS license. How do I fixed it? On provided link there is nothing.


  • Qt Champions 2016

    @flashmozzg

    Same thing happened to me.
    Did not find a fix so I ended up un install it all and install 5.5 and
    then the tooled worked again.



  • @mrjj It somehow worked out after I download online installer, logged into my account there, then run maintenance tool again - at didn't ask me for my credentials this time.


  • Qt Champions 2016

    @flashmozzg
    Ok, sort of the same I did I guess. except i deleted it all first :) doh



  • @mrjj Well the key difference here - I didn't need to reinstall qt.


  • Qt Champions 2016

    @flashmozzg
    Yeah, quite the time saver.
    I think i deleted it because it complained about folder already used or something like that.



  • @mrjj Yep. Because of that I launched maintenance tool to uninstall Qt and found out that it's now working ;)


  • Qt Champions 2016

    @flashmozzg
    Oh, i see my fail now
    I just deleted the folder :)



  • Had the same problem on Linux. If you installed Qt as root (most likely to /opt/Qt) then you'll have to run the maintenance tool as root, too. Otherwise it will look for your key in the wrong place and it also won't have write access to the installation directory. Unfortunately the start menu entry for the maintenance tool (that was created during installation) doesn't run the tool as root by default (so one has to fix this start menu entry).



  • @Wieland Thanks for the tip. I had a even more complex problem. I had logged in as a normal user, but when I installed Qt, I did it with sudo. This created the crazy situation of having the ~/.config/Qt files in my normal user directory, but had the ownership of the files in /opt/Qt be in the user of 'root'.

    So running the maintenance tool as 'root' didn't work, nor did running it as a 'normal user'.

    The fix is to run it via sudo from the normal user, just the way I did the install:
    sudo ./MaintenanceTool

    Too bad the GUI error message was so completely wrong when it said:
    No valid license available in your Qt Account for this host platform

    Also the command line warning was completely wrong when it said:
    [root@localhost Qt]# ./MaintenanceTool
    [0] Warning: Could not find Qt Account settings from the disk


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.