Important: Please read the Qt Code of Conduct -

[Solved] Resource file not found when compiling

  • When looking at my project file in Qt Creator, it indicates that I'm including 2 resource files:

    RESOURCES += \
    GUIResources.qrc \

    I can open these file in Qt Creator, and everything looks fine. When I build my project, I get the following error: [qrc_GUIResources.cpp] Error 1 File not found. When I look in the release folder, I see all the other files built by the compiler, but there are no .cpp files for the resource files.

    Under the Build menu, I've tried cleaning my project, run Qmake and finally rebuilding my project. Nothing seems to matter; I always get the same error. What am I missing?

  • Hi and welcome to devnet

    Did you check the output of qmake for warnings?
    These files might be in a different folder than qmake is searching.
    Are they in the same folder as the rest of the code?

  • @koahnig Yes, when looking at the output of the make step, this resource file was referencing another file that had been accidentally deleted. I know what to look for now. Thanks!

  • @Endless77
    You are welcome. Glad that it was as easy.

  • I feel embarrassed to admit this, but for the life of me I can't find the way to edit the thread title to mark this thread as solved. There used to be an update post button.

  • Just did mark it as solved.
    This might be because you have signed up lately. Not sure what the restrictions are, but it is meant for spam prevention.

    Otherwise at your top post respectively any other post you should see a gear wheel at the right. Click on this and on the left button showing up. In general it is self-explanatory and I am sure you will find it next time.