import QtQuick 2.5 not possible (unsupported version)



  • Hey guys,

    I just updated to qt5.5.
    When I try to import QtQuick 2.5 I get an error "unsupported QtQuick version (0:0)"

    Any idea?

    CU
    mts



  • Hi,

    which platform?
    Have updated using the Installer??



  • ah sorry:

    • windows
    • qt version 5.5
    • creator 3.4.2
    • msvc 2013

    I have updated everything.



  • Have you used the Online Installer or the Offline one??

    I'm on Mac and I upgraded 2/3 days ago; everything works ok

    // main.qml
    import QtQuick 2.5
    import QtQuick.Window 2.2
    
    Window {
        visible: true
        MainForm {
            anchors.fill: parent
            mouseArea.onClicked: {
                Qt.quit();
            }
    
        }
    }
    
    // MainForm.qml
    import QtQuick 2.4
    
    Rectangle {
        property alias mouseArea: mouseArea
    
        width: 360
        height: 360
    
        MouseArea {
            id: mouseArea
            anchors.fill: parent
        }
    
        Text {
            anchors.centerIn: parent
            text: "Hello World"
        }
    }
    

    is the standard QtQuick template with updated QtQuick version to 2.5



  • thats how my default template looks like at my installation:

    main.qml

    import QtQuick 2.4
    import QtQuick.Window 2.2
    
    Window {
        visible: true
        MainForm {
            anchors.fill: parent
            mouseArea.onClicked: {
                Qt.quit();
            }
    
        }
    }
    

    MainForm.ui.qml

    import QtQuick 2.4
    
    Rectangle {
        property alias mouseArea: mouseArea
    
        width: 360
        height: 360
    
        MouseArea {
            id: mouseArea
            anchors.fill: parent
        }
    
        Text {
            anchors.centerIn: parent
            text: "Hello World"
        }
    }
    


  • HI,

    I changed the import in the main.qml file to use version 2.5 and it works without errors



  • I can even change it to 2.5 compile and run without errors but when I try to switch to design-mode I get the error.
    Maybe I should have added that it's an error from qtCreator and not a compile or runtime-error.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.