Qt 5.5 final release + OS X 10.10.4 + Xcode 6.4 - A lot of warnings when building + error when deploying to iOS 8.4



  • Hi,
    i have problems deploying my app to iOS device (8.4).

    While building a get thousands of warnings like:
    /Users/nando/Qt/5.5/ios/include/QtCore/qabstractanimation.h:129: warning: unknown warning group '-Winconsistent-missing-override', ignored [-Wunknown-pragmas]
    Q_OBJECT
    ^

    /Users/nando/Qt/5.5/ios/include/QtCore/qcompilerdetection.h:1096: expanded from macro 'QT_DO_PRAGMA'
    #define QT_DO_PRAGMA(text) _Pragma(#text)
    ^
    <scratch space>:172:27: note: expanded from here
    clang diagnostic ignored "-Winconsistent-missing-override"
    ^

    And when deploying:

    Starting remote process.
    TransferAppSession(26d492b5d61eaee2ac5120066cd5e3ba7d094c6f, /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/AVIATOReLogbook-App.app)failed to get app Path on device for bundle /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/AVIATOReLogbook-App.app with appId: aero.aviatorsoft.AVIATOReLogbook-App
    TransferAppSession(26d492b5d61eaee2ac5120066cd5e3ba7d094c6f, /development/qtcreator-workspace/build-AVIATOReLogbook-iphoneos_clang_Qt_5_5_0_for_iOS-Debug/AVIATOReLogbook-App/Debug-iphoneos/AVIATOReLogbook-App.app)Unexpected reply: ENo such file or directory () (454e6f20737563682066696c65206f72206469726563746f7279202829) vs OK (4f4b)
    Run ended.

    Any ideas whats happened?

    This happened just after upgrading OS X and Xcode...

    Greetings
    Nando


  • Lifetime Qt Champion

    Hi,

    This is a known problem that has been fixed for 5.5.1, if you need the fix now you can apply the patch needed against Qt 5.5.0 and rebuild Qt yourself.





  • Hi,
    and thank you for the information with the patch.

    Does the patch fix also the deployment problems or just the warning stuff?

    Greetings
    Nando



  • I haven't tried to deploy anything yet to be honest. The patch looks unrelated to that type of problem...



  • I had similar issue with Qt 5.5.1 and c++14 code. Adding CONFIG += c++14 did not work, the same errors still showed up.

    I tried CONFIG += c++11 c++14, which worked, fortunately.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.