5.5.0 build error on RPi2



  • Building 5.5 get the following error (GCC 5.9.2). Config is the same as for 5.4 which builds fine without this error:

    g++ -c -O2 -pipe -fexceptions -fno-rtti -march=armv6zk -mtune=arm1176jzf-s -mfpu=vfp -I/usr/local/include -O2 -fvisibility=hidden -fvisibility-inlines-hidden -std=c++0x -fno-exceptions -Wall -W -D_REENTRANT -fPIC -DQT_NO_TSLIB -DQT_NO_LIBINPUT -DQT_BUILD_XCB_QPA_LIB_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQT_BUILD_XCB_PLUGIN -DXCB_USE_XLIB -DXCB_USE_XINPUT2 -DLIBXI_MAJOR=1 -DLIBXI_MINOR=7 -DLIBXI_PATCH= -DXCB_USE_SM -DXCB_USE_RENDER -DDFLT_XKB_CONFIG_ROOT="/usr/local/share/X11/xkb" -DDEFAULT_XKB_RULES="evdev" -DDEFAULT_XKB_MODEL="pc105" -DDEFAULT_XKB_LAYOUT="us" -DQ_FONTCONFIGDATABASE -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_PLATFORMSUPPORT_LIB -DQT_GUI_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I. -I../../../../include -I/mnt/mmcblk0p2/SRC/Work/Qt5/qt-everywhere-opensource-src-5.5.0/qtbase/include/QtQGui -I../../../../include/QtGui/5.5.0 -I../../../../include/QtGui/5.5.0/QtGui -Igl_integrations -I../../../3rdparty/xcb/include -I../../../3rdparty/xcb/sysinclude -I../../../3rdparty/xkbcommon -I../../../3rdparty/xkbcommon/xkbcommon -I../../../3rdparty/xkbcommon/src -I../../../3rdparty/xkbcommon/src/xkbcomp -I../../../3rdparty/xkbcommon/src/x11 -I../../../../include/QtPlatformSupport -I../../../../include/QtPlatformSupport/5.5.0 -I../../../../include/QtPlatformSupport/5.5.0/QtPlatformSupport -I../../../../include/QtGui -I../../../../include/QtCore/5.5.0 -I../../../../include/QtCore/5.5.0/QtCore -I../../../../include/QtDBus -I../../../../include/QtCore -I.moc -I../../../../mkspecs/linux-g++ -o .obj/qxcbconnection_xi2.o qxcbconnection_xi2.cpp
    qxcbconnection_xi2.cpp:634:80: error: operator '&&' has no right operand
    #elif LIBXI_MAJOR == 1 && (LIBXI_MINOR < 7 || (LIBXI_MINOR == 7 && LIBXI_PATCH < 4))
    ^
    Makefile.xcb_qpa_lib:8266: recipe for target '.obj/qxcbconnection_xi2.o' failed
    make[6]: *** [.obj/qxcbconnection_xi2.o] Error 1



  • This is a shot in the dark, but are you using the -j option with make? If so, have you tried running make without the -j right after the error occurs? I have had this happen when building for MinGW with gcc. If that doesn't work you can try make 2>errors.txt to get a text file of all the errors that are occurring.
    Paul



  • I got this problem when I configured, installed xcb, reconfigured, and then make'd. Doing a clean out-of-source build worked for me.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.