Query users limited to 100



  • Hi,

    When requesting a list of users from the cloud, I can't seem to get a list bigger than 100 users. I added "limit": 1000 to the request, but I still only get 100.

    When I set the limit to 10 though, only 10 users are returned, so the limit parameter does seem to work somewhat. Note that setting the limit to 1000 for normal objects does work: I get a list with more than 100 items then.

    Greetings,
    JeDi



  • Hi,

    Are you setting the limit as URL parameter this way:

    GET https://api.engin.io/v1/users?q={"lastName":"Doe"}&limit=2
    

    Could you dump the request that is being sent, strip away any secrets etc. so we can have a look what might be the issue.

    Cheers,
    -Jussi-



  • Thanks for the reply. This is the request sent to the cloud:

    {
        "limit": 1000,
        "objectType": "users",
        "query": {
            "hidden": false,
            "isPatient": true
        },
        "sort": [
            {
                "direction": "asc",
                "sortBy": "firstName"
            },
            {
                "direction": "asc",
                "sortBy": "lastName"
            }
        ]
    }
    

    Note that setting the limit to 10 for example, does work. I only get 10 records than.



  • I found a workaround!

    There seems to be a bug that resets the limit if it is 1000 or more. When I set it to 999, I get all my users. When I set it to 1000 or more, I only get 100.

    Should I mark this post as solved? I found a workaround, but there still seems to be a bug in the query system.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.