Please nominate your Qt Champions for 2021!

[SOLVED] Problems to build for Android

  • Hello all.

    I am having a problem to build the app for Android.

    I am using OSX Yosemite, Qt 5.4.2, the last version of Android SDK, Android NDK and Ant and Java 8 update 45

    After configuring everything it was building normally. When I entered in Projects > Build Android APK and clicked in Create Template all my Android Projects stop working. It returns this message:

    /Users/guilhermedupas/AndroidTools/android-sdk-macosx/tools/ant/build.xml:649: The following error occurred while executing this line:
    /Users/guilhermedupas/AndroidTools/android-sdk-macosx/tools/ant/build.xml:655: Execute failed: Cannot run program "/Users/guilhermedupas/Dropbox/Desenvolvimento/Qt/ProjetosQt/build-FinanceC-Mobile-Android_for_x86_GCC_4_9_Qt_5_4_2-Debug/android-build/${aidl}": error=2, No such file or directory
    Caused by: error=2, No such file or directory
    at java.lang.UNIXProcess.forkAndExec(Native Method)
    at java.lang.UNIXProcess.<init>(

    The process "/Users/guilhermedupas/Qt5.4.2/5.4/android_x86/bin/androiddeployqt" exited with code 14.
    Error while building/deploying project FinanceC-Mobile (kit: Android for x86 (GCC 4.9, Qt 5.4.2))
    When executing step "Build Android APK"

  • Is your compilation error equal than this? If so, you are not the only one who have the problem, and it seems that the root is not you operating system like I've thought in the beginning, because I use Linux and the author of the other thread uses Windows.

    It seems that an update of Android SDK broke the compatibility with Qt, and I asked to Google by the situation, but it doesn't want to know anything about this topic.

    It seems we have to wait for an update in Qt to solve the problem.

  • Yes...running into same issue after updating SDK tools. First I think it was a problem about wrong set env paths. But it seems that something is really broken.

    After updating to latest SDK Tools 24.3.3 the problem is solved. Did not know what they have changed but also in Release Notes there is a note to update because of build problems.

  • @sk2212 , @Cold_Distance

    Thanks for the help. Thats is correct, updating the SDK Tools to 24.3.3 solved the problem.

Log in to reply