How to add new library to an existing library in qt [Solved]

  • Hi
    I'm new in QT and QT community.
    Please help me in these questions.
    1-I'm trying to make a device who has a rich graphic let say something like "Nest thermostat" graphic or similar. Am I in a correct place? If I'm not what is the best tool(s) for this?
    2-I was make a Qt from source in QT version 4.8.2 for cross compiling with Beagle bone black. later on I found out I didn't install
    In this situation can I add only this library to my existing library or I have to redo my configure with adding that in the end.
    BTW my host and target machine work on Debian.
    Host is running Jessie Debian, and target is running Wheezy Debian.
    Thank you

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Any reason not to use Qt 4.8.7 ?

    Do you have tslib available for your board ?

  • @SGaist
    Thank you for your reply.
    As I'm new in Qt I have no idea about deferent versions. I just followed the Derek molly book.
    I have tslib in my board and I can run ts_calibrate and ts_test, and they are working perfectly.
    Does it mean it's active on my board or I have to do something special like run configure in tslib directory?
    My problem is when I cross compiling my program on my board, the touch screen is not calibrate and it's seems X and Y swap.
    I run
    export TSLIB_TSDEVICE=/dev/input/event1
    export TSLIB_CONFFILE=/etc/ts.conf
    export QWS_MOUSE_PROTO=tslib:/dev/input/event1(and also run export QWS_MOUSE_PROTO=LinuxInput:/dev/input/event1)
    but after that when I run my Qt application again this time touchscreen doesn't move at all.
    Do you think I'm missing some steps?
    Thank you

  • Lifetime Qt Champion

    Always take a look at the download section for the latest version. Beware of one thing though, Qt 4.8.7 is the last release of the 4 series (except for security fixes if any would arise)

    If you have the development package available when cross-compiling just ensure that you pass the correct configure flag. This way if it's not found, you'll have an error message.

    The exports you are doing are looking and since it looks like you have tslib up and running on your board, it should be enough.

  • @SGaist
    One point I have to say is if I run ts_calibrate in command line it doesn't work unless I run these lines:
    export TSLIB_TSDEVICE=/dev/input/event1
    export TSLIB_CONFFILE=/etc/ts.conf

    1-Does it still mean tslib is up and running?
    2- I run clean configure and configure again and this time i added -qt-mouse-tslib in end of configure(before i didn't add this)
    when everything done(make-make install) I couldn't see any new library on lib directory and lib directory has a same library as before.
    Is it normal?

    I look at this location :"/usr/local/qt4.8.2-armhf/lib" this is the prefix definition for configure.

    old configuration:
    ./configure -v -opensource -confirm-license -xplatform linux-arm-gnueabihf-g++ -embedded arm -little-endian -host-little-endian -prefix /usr/local/qt4.8.2-armhf -nomake demos -nomake examples -no-qt3support -qt-gfx-linuxfb -qt-gfx-qvfb -qt-gfx-vnc -no-accessibility

    New configuration:
    ./configure -v -opensource -confirm-license -xplatform linux-arm-gnueabihf-g++ -embedded arm -little-endian -host-little-endian -prefix /usr/local/qt4.8.2-armhf -nomake demos -nomake examples -no-qt3support -qt-gfx-linuxfb -qt-gfx-qvfb -qt-gfx-vnc -no-accessibility -qt-mouse-tslib

    Thank you


  • Lifetime Qt Champion

    1. Yes it does, tslib need to know which device it should handle (that's TSLIB_TSDEVICE) and how it should handle it (that's TSLIB_CONFFILE)
    2. -qt-mouse-tslib means that you have the support built-in Qt not as a plugin. So yes it's normal

  • @SGaist
    Thank you so much

  • Lifetime Qt Champion

    You're welcome !

    If that answers your question, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

    Also, up voting the answers that helped you will allow other users to get to the solution more quickly

  • This is my solution.

    after I added -qt-mouse-tslib to my configure as I put it in last comment (with title New configuration) and scp entire lib to BBB,
    I setup my tslib environment and after I calbrated it everything is working.
    I will put my full steps when I get chance.
    Thank you

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.