QT picks up ActiveX components that are not installed



  • Hi All

    I have an ActiveX component that I uninstalled from my machine but QT still sees it.
    WHy?
    The supplier created a new Component and I need to install the new component on my machine.
    I have done so but QT still see the old ActiveX components.
    What am I missing?
    Kind regards
    Ben



  • Hi, it could be that the registry in your machine still points to the old DLL, perhaps uninstalling didn't delete everything from the registry.
    If you have the new version of the file, you can try to install it manually, using the regsvr32 command, like this:
    regsvr32 C:\Downloads\NewComponent.dll



  • @hskoglund
    Thank you. I have tried but get entry-point DllRegisterServer was not found error?



  • Ok, it could be that the new Component is a .NET dll, in that case you'll get this error.
    If this is the case, you need to change your Qt code that calls the component :-(
    if you can find a new .LIB or .TLB file for the new Component that would help.



  • Hi
    I'm in discussion with the OEM for the component but the guy that did the OCX is long gone.......
    I can see that my component is giving a response to my requests but the driver below the ocx for the hardware is for some reason not "connecting" with the component.

    Any suggestions?
    Ben



  • Hmm, could be a 32-bit/64-bit mismatch, and I assume you've tried launching the app as an administrator.
    Also, maybe there is a test program for the hardware, i.e. checking it's not the hardware having a bad day..


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.