SLED 11 SP1, run qt4 OpenGl examples ,Error:lack glu.h



  • hi all,
    when i install the latest qt sdk in my SLED 11 SP1 , run one example of OpenGl , the IDE report to me :
    /home/compiler/qtsdk-2010.05/qt/examples/opengl/2dpainting-build-desktop/../../../include/QtOpenGL/qgl.h:79: error: GL/glu.h: No such file or directory

    When i google this problem ,some one tell me to install libgluxx.so ,etc. But my problem is going on .

    My SLED have installed mesa 7.7-0.4.41 (i586) .

    help me ,please ~~~~~~~~~~



  • Would it be an option to upgrade to the Qt SDK 1.1? The version you are using is almost a year old. Not sure if that will help, but at least you'll have the latest version of everything.



  • Have you installed the mesa-devel package?



  • my Qt SDK is 1.1RC ;
    mesa-devel ?? I havn`t known it before , but I find "libglu1-mesa-dev" .
    Can you tell me the full name of "mesa-devel " ?



  • For OpenSuSE 11.3, I have Mesa-7.8.2-1.3 and Mesa-devel-7.8.2-1.3.

    @
    ~> cat /etc/SuSE-release
    openSUSE 11.3 (i586)
    VERSION = 11.3
    ~> rpm -q --whatprovides /usr/include/GL/glu.h
    Mesa-devel-7.8.2-1.3.i586
    ~> rpm -qa | grep Mesa
    Mesa-7.8.2-1.3.i586
    Mesa-devel-7.8.2-1.3.i586
    @



  • ok ,I will try it .


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.