[Partially Solved] Cannot Connect to QML Emulation Layer

  • So everything was working fantastic. I was editing UIs, writing code and testing all without issues.
    I changed sessions to view some code from another project I had and then changed back.
    Now whenever I try to enter Design mode for QML UIs I am presented with the following error:
    "Cannot Connect to QML Emulation Layer (QML Puppet)
    The executable of the QML emuilation layer (QML Puppet) may not be responding. Switching to another kit might help."

    Switching to another kit did not help.
    I also tried closing Qt Creator and reopening it. No luck.
    Restarted my PC. Also no luck.

    Does anyone have any ideas for why this may be happening? It seems to have happened out of nowhere. I've had no issues changing sessions in the past. Thankfully QML is easy enough that this isn't the end of the world, but I'd much rather work with a visual designer than type my UI by hand.


    Edit: Also worth mentioning is that when I run my program since this error started, QtCreator hangs for around 5 seconds before displaying my program. Usually it's instantaneous. Strange stuff!

    Edit2: Solved by reinstalling Qt Creator. Not sure what the deal is, but I guess I'll refrain from switching sessions for now :P

  • Lifetime Qt Champion


    Which version of Qt and Qt Creator ? IIRC that's something that has already been fixed

  • @SGaist Qt Creator 3.4.0 with Qt 5.4.1. Reinstalling it somehow fixed the issue. Still seems very strange..