Why I can't install my sis package on phone?



  • If I deploy my App with QT 4.6.3. All work fine.
    When I build-deploy app with QT 4.7.2, sis package created ok. But when I install my package on phone, this error happened: "Unable to install".
    I did the same steps with QT 4.7.3, sis package created. But can not installed on my phone. When install sis package on phone. I saw this message "this app require QtMobility 1.0.1(3) or higher".
    My phone model is E72, with latest firmware.
    I try all QtMobility version that downloaded from Nokia, but it don't work.
    How can I get latest QtMobility version Or how can I resolve this problem?.
    Thanks a lot!



  • Which was the highest version of QtMobility you have installed? Mine is 1.1.2 and it is OK... with the previous versions I've had problems too.
    Which version of Qt do you have on the phone?



  • [quote author="hungchuviet" date="1303763135"]
    How can I get latest QtMobility version Or how can I resolve this problem?.
    [/quote]

    Use Nokia Smart Installer to make sure that the appropriate version of Qt Mobility will be deployed on the phone prior the installation of your application. For more information please read the article about "Nokia Smart Installer for Symbian at Forum Nokia":http://wiki.forum.nokia.com/index.php/Nokia_Smart_Installer_for_Symbian

    Cheers,
    Leon



  • I try all things:

    • Use nokia smart installer.
    • Careful check all require component.
      But I cant not install app on phone.
      On my phone: Qt 4.7.3 for Symbian^1, QtMobility 1.1.2 for Symbian^1. (It is highest QtMobility that I know).
      Help me!


  • [quote author="hungchuviet" date="1303798367"]I try all things:

    • Use nokia smart installer.
    • Careful check all require component.
      But I cant not install app on phone.
      On my phone: Qt 4.7.3 for Symbian^1, QtMobility 1.1.2 for Symbian^1. (It is highest QtMobility that I know).
      Help me![/quote]

    Using Nokia Smart Installer you should create a new sis file and to install it on the device. It will automatically check for dependencies and download required libraries. See "packaging details at this article. ":http://wiki.forum.nokia.com/index.php/Qt_Application_Packaging_and_Signing_Checklist

    Have you tried your application on other devices? Use "Nokia RDA to test it.":http://www.forum.nokia.com/Devices/Remote_device_access/



  • Thanks you very much!
    I'll try RDA, It's very nice!
    Thanks!



  • [quote author="hungchuviet" date="1303838936"]Thanks you very much!
    I'll try RDA, It's very nice!
    Thanks![/quote]

    Hi,

    Did you solve the issue? Is the installation problem present on Nokia remote devices?

    Regards,
    Leon



  • Just a question, on what phone do you develop? Does the phone has Qt framework already installed onboard ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.