Please Help: Qt 4.8.5 Configure Getting Stuck



  • Hello,

    I need to intsall Qt 4.8.5 on my Ubuntu 14.04 LTS machine in order to use it to compile another program. I have been struggling with this program now for a frustrating amount of time trying to get all of the dependencies (i.e. Xrender, Xcursor, etc.) installed to the point where it is no longer complaining about them and now it is stalling when I run configure.

    I first installed the Qt 4.8.5 and everything appeared to work all right (it turns out the warning messages were so buried in the output that I overlooked them), but then when I tried to compile my program it quit with an error saying that QWebKit wasn't installed, which I have since figured out is because Xrender, Xcursor, and Xrandr were not installed.

    Now when I run ./configure it is getting a fair amount of the way in and then reaching the following:

    Reading %PATH%/qt-everywhere-opensource-src-4.8.5/demos/spectrum/app/app.pro
    INPUT FILE NAME

    and waiting for me to input some file name. Problem is, I have no idea what it is looking for and anything that I put in just results in the following error, where configure is apparently stalling:

    **** WARN: specified file does not exist ****


    **** WARN: halting program in SEIOPEN ****
    **** ...closing down files ****
    cat: .projects.all.*: No such file or directory

    I'm wondering if this is either a result of maybe not being uninstalled cleanly before reinstalling it, or if there is some file that I need to specify that I am just completely overlooking.

    Any help will be greatly appreciated!

    Thanks.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you restart your configuration from a clean source ?



  • @SGaist Thank you for responding.

    Yes, I did restart it from a clean source. I've tried running make confclean and just plain recopying the source and both do the same thing.


  • Lifetime Qt Champion

    What options did you give to configure ?



  • @SGaist None.


  • Moderators

    Hi @komjongshawn,

    May I suggest installing Qt 4.8.5 from the Ubuntu repository? (e.g. apt-get or Ubuntu Software Center)

    Get the "libqt4-dev" package. That pulls in all the required dependencies for build Qt 4 applications.

    If a module is left out for some reason, just search for packages that start with "libqt4-".



  • @JKSH

    Thanks. I installed libqt4-webkit and that was enough to eliminate the errors related to Qt. I'm getting another error when I actually try to compile my program, but it looks like that's a result of bad programming by the author, so not too much that can be done there other than trying to sort out his code.

    Thanks for your help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.