Nominate our 2022 Qt Champions!

[Partly Solved] [QtCreator+GitLab] SSH-Agent: Timeout and unable to do anything

  • Update: Just to test something, I created a Public Repository: I cannot even clone this. It simply runs until I click "cancel".
    Update 2: I tried cloning 1x public GitLab and 1x public GitHub Project per HTTPS (by using Qt's Import Project Option) and it works.
    Connecting per SSH with QtCreator is a complete mess as QtCreator seems bugged as hell (which is the usual case) or it has horrible compatibility Issues. I dont know. I am not Qt pro enough. But one thing's for sure: Another reason why I hate Creator has been added to the List.
    Hello Forum.

    I have a Problem with connecting to GitLab.
    I followed this Page and created the .bashrc File and put it on my
    Users Folder. [Yes its a GitHub Tut but it is about Git Bash and therefore it should not matter...]

    So far, so good:
    When I start the Git Bash, it asks for the Password and keeps running. But no matter if I start the Bash before or after I started QtCreator, I can not connect to GitLab. The Error Message is:

    11:07 Executing in D:\MeineProgramme\GitProjects\AKKomPolTool: C:\git\bin\git.exe status --untracked-files=no --ignore-submodules=all --porcelain -b
    11:07 Executing in D:\MeineProgramme\GitProjects\AKKomPolTool: C:\git\bin\git.exe pull --rebase
    The command "C:\git\bin\git.exe" did not respond within the timeout limit (60000 ms).

    Connecting per SSH Key to GitLab with 3rd Party Software like SmartGit and SourceTree works fine.
    No Firewall or AntiVirus Software Problems.

    Operating System:

    • Windows 7 x64
    • UAC Status: Completely Disabled
    • Git Tools and QtCreator running as Admin: Yes (Account has Full Admin Rights by Default)

    Software Versions:

    • QtCreator: 3.3.1 (Official Release Version)
    • Git: 1.9.5 Preview from

    I also emptied the Field "SSH prompt command" unter Tools -> Options -> Version Control -> General. Nothing works.
    And what about the Fields "Gitk - Arguments" and "Repository Browser - Command" in the Git Tab: Do I need to put something in there?

    I am not sure what else I can do. Any Hints / Tips are much appreciated.


  • Good morning Forum.

    After a long time not being able to use QtCreator with a SSH Key, I decided to go the dirty way and did the following:
    A.) In QtCreator under Tools -> Options -> Version Control -> General -> SSH prompt command: emptied the Field completely
    B.) Deleted the current SSH Key and created a new one WITHOUT a Password.

    Now I am being able to pull. I hope the rest will work too. Will check these things during the weekend.

    @QtCreator Devs: In case anyone of you see this by accident: Is there any chance that QtCreator gets a "Enter User Name and Password Field" in the near future? I really would prefer to use a SSH Key with a Password.

    Have a good Day everyone.


  • Lifetime Qt Champion


    To discuss that matter, you should rather got to the Qt-Creator mailing list you'll find there Qt Creator's developers/maintainers (this forum is more user oriented)

  • @SGaist Morning.

    Yes I know that this Forum is more Community driven. When I find the time, I will propably ask that on the Mailing List. [Thanks for the direct Link btw]

    Have a nice weekend.