Important: Please read the Qt Code of Conduct -

Qt GUI Application does not display labels on Windows Embedded Compact 7

  • Greetings fellow developers,

    I recently deployed two applications on a Windows Embedded Compact 7 device, a Qt Quick 2 application and a Qt GUI (Widget) application. Both applications work fine, but the Qt GUI application does not show any labels, neither on buttons nor on QLabel instances. I toyed arround with several different fonts and colors, but without success. There are no error messages at runtime or at compiletime that indicate any problem regarding fonts. The Qt Quick 2 application does not show this kind of error, all labels are displayed, correctly.
    Both applications work fine in a desktop environment, everything is shown.

    Things I have tried so far:

    • Changing font color and background color.
    • Increasing font size.
    • Using various fonts that are present on the target system, like Arial.
    • Deactivated font antialiasing.
    • Switched to rich font and real font.
    • Copied all font files for the target system to the application directory I run the application from.

    System information:

    • Qt 5.4.1 for Windows CE, compiled by myself for the target system. The configuration used is shown below.
      configure -platform win32-msvc2008 -xplatform wince70embedded-armv4i-msvc2008 -nomake examples -no-accessibility –opengl es2 -opensource -release –skip activeqt –skip winextras –prefix <InstallDir>
    • Qt Creator 3.2.1 as developement platform.
    • ARM v4i based board

    I have no further clue how to solve this problem, maybe someone has further insight regarding this problem. If neccessary, I could provide some code, but the application is very simple, containing a single button and two labels. If further information is required, I will provide it, gladly.

    Thanks in advance.

  • Hi,
    This problem looks similar to my question I asked few days ago. QML APP looks good except fonts.
    My target is Intel Atom E6xx Windows Embedded Standard 7, but maybe the problem is somehow related.

    What can help you:
    Check what version of OpenGL is present on your platform. It is usually version 1.1 on Windows, but QT needs > 1.1
    Check if you can use ANGLE on WIN CE configuration. This will use DirectX 9 or 11 to display QtQuick.

    You can find more information hire:

  • @joska

    Thanks for the insight. The problems might be related, but in my case QtQuick works fine, only Qt widget based applications yield this error. OpenGL version on platform is ES 2.X and hardware acceleration is available, at least to standalone QpenGL applications.

Log in to reply