[SOLVED]Can't connect to MDB via tunnel

  • I want to use ssh tunnel that I got from MDB settings of Remote access.
    But it seems hang forever when I try to connect to remote database host.
    I recreated MDB instance several times, changed localhost, tried to connect from Linux and OS X, cleared ssh keys, but problem didn't disappeared.

  • I have the same problem.
    Ifinite connection time to MDB ssh port.

  • cid:52:privileges:purge

    Ssh tunnel hanging is the correct behaviour (at least with openssh). If it does not say any errors then ssh tunnel is open. Just open another terminal/tab and connect to your MDB instance through the tunnel. Tunnel is closed when "hanging" ssh command is terminated (ctrl+c).

  • @jakolehm Thank you. Yes I could connect to MDB from second terminal. But I got one syntax problem.
    If I type

     mysql --host= --port=49282 --user=admin --password=<password> 

    everything ok. But when I try

     mysql -h -P 49282 -u admin -p <pass> 

    it asks my password, and when I put it hang forever again

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.