buildroot qt issue with tslib



  • Hi,
    I am working on buildroot-2014.05 for Renesas RSKRZA1 board. Here ts_test, ts_calibrate are working fine, but none of example in QT-4.8.6 is working with touch panel. I have selected tslib package in QT in buildroot menuconfig, it was in mouse driver.

    Please let me know the solution if anyone knows.

    Thanks in advance.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you create the configuration files for tslib to use ?

    You can set the QT_DEBUG_PLUGINS environment variable when you run your application to get some more information.



  • @SGaist said:

    configuration files for tslib

    Thanks devnet,

    It was already created /etc/ts.conf file. There were some settings left. These are:
    export TSLIB_TSDEVICE=/dev/input/event0
    export TSLIB_TSEVENTTYPE=INPUT
    export TSLIB_CONFFILE=/etc/ts.conf
    export TSLIB_CALIBFILE=/etc/pointercal
    export QWS_MOUSE_PROTO="Tslib:/dev/input/event0"

    Actually I am new to this, after search in google I have found these. Now every qt example is working with touch.


  • Lifetime Qt Champion

    Good !

    Then please mark the thread as solved ("Topic Tools" -> Mark Solved)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.