14.04.2 qt creator



  • I apologize beforehand, I know bad English, and this use google translators.
    the problem started after the transition to the new graphics stack in ubuntu 14.04.2, namely after
    @sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic xserver-xorg-input-all-lts- utopic @
    when you try to build the project QApplication
    gives an error: -1: Error: can not find -lGL
    but when I try to run sudo apt-get install libglu1-mesa-dev -y
    writes
    @ Reading package lists ... Done
    Building dependency tree
    Reading state information ... Done
    Some packages could not be installed. Perhaps you are asking the impossible,
    or using the unstable distribution that some required
    packages have not yet been created or been moved out of Incoming.
    The following information may help you:

    The following packages have unmet dependencies:
     libcheese-gtk23: Depends: libclutter-gtk-1.0-0 (> = 0.91.8) but it will not be installed
                       Depends: libcogl15 (> = 1.15.8) but it will not be installed
     libcheese7: Depends: libclutter-gst-2.0-0 (> = 0.10.0) but it will not be installed
                  Depends: gstreamer1.0-clutter but it will not be installed
     libclutter-1.0-0: Depends: libcogl-pango15 (> = 1.15.8) but it will not be installed
                        Depends: libcogl15 (> = 1.15.8) but it will not be installed
    E: Error, pkgProblemResolver :: Resolve generated breaks packages. This may be caused by delayed (held) packages. @

    проблема началась после перехода на новый графический стек в ubuntu 14.04.2, а именно после выполнения
    @sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic xserver-xorg-input-all-lts-utopic@
    при попытке собрать проект QApplication
    выдаёт ошибку :-1: ошибка: cannot find -lGL
    а при попытки выполнить sudo apt-get install libglu1-mesa-dev -y
    пишет
    @Чтение списков пакетов… Готово
    Построение дерева зависимостей
    Чтение информации о состоянии… Готово
    Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
    или же используете нестабильную версию дистрибутива, где запрошенные вами
    пакеты ещё не созданы или были удалены из Incoming.
    Следующая информация, возможно, поможет вам:

    Пакеты, имеющие неудовлетворённые зависимости:
    libcheese-gtk23 : Зависит: libclutter-gtk-1.0-0 (>= 0.91.8) но он не будет установлен
    Зависит: libcogl15 (>= 1.15.8) но он не будет установлен
    libcheese7 : Зависит: libclutter-gst-2.0-0 (>= 0.10.0) но он не будет установлен
    Зависит: gstreamer1.0-clutter но он не будет установлен
    libclutter-1.0-0 : Зависит: libcogl-pango15 (>= 1.15.8) но он не будет установлен
    Зависит: libcogl15 (>= 1.15.8) но он не будет установлен
    E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.@


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You should rather bring this question to the Ubuntu guys. It looks like your last update failed so you can't go further.



  • Same issue here.....solved by doing the following:

    sudo apt-get libgl1-mesa-dev-lts-utopic
    sudo apt-get libgl1-mesa-dev
    sudo apt-get install libqt4-dev



  • thank you all!!
    it worked fine after this:
      @sudo apt-get install libgl1-mesa-dev-lts-utopic@
    отлично всё заработало после выполнения этого:
    @ sudo apt-get install libgl1-mesa-dev-lts-utopic@


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.