Problem with mingw-make32.exe on ancient Qt (2010.01)



  • I've had Qt 2010.01 installed on my machine for months, and it worked perfectly. Now I suddenly have problems with mingw32-make.exe.

    Whenever I try to do a build, or even a make clean, I get a message like this:
    C:/Qt/2010.01/mingw/bin/mingw32-make -f Makefile.Release clean
    process_begin: CreateProcess(C:\Users\steve\AppData\Local\Temp\make8320-1.bat, C:\Users\steve\AppData\Local\Temp\make8320-1.bat, ...) failed.
    make (e=5): Access is denied.
    mingw32-make[1]: [clean] Error 5 (ignored)

    I have tried the following:

    • Uninstalling and reinstalling Qt (including the mingw stuff).
    • Creating a brand new console project with no code other than that generated by Qt to test whether the problem is with my project or not.
    • Changing the TMP path variable to point to somewhere new, that I definitely have write access to, so that the .bat files can be written to test if it's a file permissions problem.
    • Running QtCreator as administrator.

    I get the same problem every time, even with a make clean (so it's not compiler related).

    I can't upgrade my version of Qt right now. Besides which, it was working just fine and now it isn't. I don't know what changed.

    Can anybody help, please?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you change/update your antivirus ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.