Building QT5 webengine - C++11 support is required error



  • Hello everyone,

    I've been trying to build QT's webengine from source lately and have been continuously running into problems. QT will build everything except webengine (the module I actually want) successfully. When it gets to webengine, jom (and nmake) report "C++11 support is required in order to build chromium. QtWebEngine will not be built."

    I've downloaded and gone through the depot_tools for chromium, made sure I'm on the dev branch, I'm running MSVC 2013 community edition, I've made sure that windows 8 sdk and windows 7.1 driver kit is installed, I've set all of the PATH components and the WDK_DIR env variables, I've even dug into the source code to see what is triggering the check and then manually entered QT_CONFIG+= C++11into the pro files figuring it was missing somewhere. Still, the build process complains that I do not have c++11 support. Anyone have any suggestions on what else to try?

    Configure settings: -nomake tests -nomake examples -confirm-license -opensource -opengl es2 -angle -debug -c++11

    (I've tried -debug-and-release and -prefix before as well but read in the past that both of those had issues with webengine)

    Environment: Clean Windows 7 VM
    MSVC 2013 community edition
    Python 2.7.6
    Perl 5.20.1



  • I use the following in my .pro files for C++11 support:

    @QMAKE_CXXFLAGS = -std=c++11
    CONFIG += c++11@

    I have no idea if this has anything to do with your specific problem thou...


  • Moderators

    [quote author="mikek_dk" date="1423494786"]I use the following in my .pro files for C++11 support:

    @QMAKE_CXXFLAGS = -std=c++11
    CONFIG += c++11@
    [/quote]If you write Line #2, then you don't need Line #1 anymore.



  • Nope, have both of those set in qtwebengine.pro with the error still occurring unfortunately (and set in the file for qt_build_config as well, for good measure)


  • Moderators

    I'm afraid I don't have experience with building Qt WebEngine. Have you tried going through "this article":http://qt-project.org/wiki/QtWebEngineOnWindows ? You probably don't need to check out from git since you already have the source code.



  • That's the article I've been following. Everything works fine up until the build stage and then the c++11 support error doesn't let webengine build.


  • Moderators

    Try asking at the "Interest mailing list":http://lists.qt-project.org/mailman/listinfo/interest (you need to subscribe first). Qt engineers are active there, and they probably know more.


  • Moderators

    And it looks like a solution was found: http://comments.gmane.org/gmane.comp.lib.qt.user/15243


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.