[SOLVED] Permission denied when building?



  • Hello, I have tried to build wpa_gui, a Qt GUI for wpa_supplicant. Whenever I build I encounter an error like this:

    09:52:23: Running steps for project wpa_gui...
    09:52:23: Configuration unchanged, skipping qmake step.
    09:52:23: Starting: "/usr/bin/make"
    ../wpa_gui-qt4/wpagui.ui -o .ui/ui_wpagui.h
    make: execvp: ../wpa_gui-qt4/wpagui.ui: Permission denied
    make: *** [.ui/ui_wpagui.h] Error 127
    09:52:23: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project wpa_gui (kit: Qt 4.8.5 (System))
    When executing step "Make"
    09:52:23: Elapsed time: 00:00.

    Can anyone please help me understand what's going on? Thanks


  • Moderators

    Hi,

    Does the user with which you have logged in or trying to build that application have write permissions of wpa_gui-qt4 directory ?



  • Hello p3co,

    I have changed the permissions for the directory recursively via chmod -R, and I can now build the project (though with some errors). Thanks for your suggestion.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.