[SOLVED] Building Qt 5.4 on FreeBSD 10.1:failed to build qlalr



  • Hello, I try to build Qt 5.4 on FreeBSD 10.1 in release mode with the qmake.conf that I created for Qt 5.2.1.I have built libqt5core with a few corrections but I have a problem when building qlalr:undefined reference to backtrace symbols and undefined reference to backtrace. I have looked a the makefile of qlalr but I don't see why I have this error because I'm building in release mode.has someone an idea ?



  • I think I will remove the qlalr project of the src.pro of qtbase and configure and build qt again because qlalr is not used by qtbase....and I need only to build the module qtbase...



  • I have the same problem for the tools qtdbusxml2cpp and qtdbuscpp2xml and so I have built qplatformsupport without accessibility (but it's not a problem because I don't use these library in my application) but I have the same linking problem with uic (undefined reference to backtrace symbols and undefined reference to backtrace) and I couldn't build libqt5widgets and I must find a solution (I have built libqt5core,libqt5network,libqt5dbus,libqt5gui, but not libqt5widgets)


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What symbols are missing ?



  • Hi, backtrace symbols are missing but I think that my QT libraries are not well build because when I try to link them with the tools I have this error. I try to build Qt in shared release mode.the compiler on FreeBSD 10.1 is clang 3.4



  • The problem is solved,I have added -L/usr/lib -lexecinfo to the makefiles of the tools of Qt and I could compile the module Qtbase,the tools of Qtbase and other Qt librairies.but I added this too the makefile of my projects.so I think I should have add QMAKE_LIBS= -lexecinfo to the qmake.conf of my mkspecs(didn't try this last thing) to avoid adding this to each makefile.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.