[solved] Qt Embedded with OpenGL ES build problem

  • Hallo,

    I am trying to build the Qt Embedded libs with OpenGL ES support. For OpenGL ES I am using the Mesa driver version 7.9.2, which I have successful compiled. Now I'm trying to compile Qt Embedded 4.7.2 with the following configuration:
    @./configure -embedded x86 -qvfb -DQT_QWS_CLIENTBLIT -DQT_NO_QWS_CURSOR -opengl es2 -nomake examples -nomake demos -nomake tools -no-gtkstyle -no-openvg -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-xinput -no-xkb -no-glib -no-qt3support -opensource -confirm-license

    Now I got stuck with a compile error:
    @In file included from ../../include/QtCore/qurl.h:1,
    from ../../include/QtGui/private/../../../src/gui/text/qtextdocument_p.h:69,
    from ../../include/QtGui/private/qtextdocument_p.h:1,
    from ../../include/QtGui/private/../../../src/gui/text/qtextengine_p.h:70,
    from ../../include/QtGui/private/qtextengine_p.h:1,
    from ../../include/QtGui/private/../../../src/gui/text/qfontengine_p.h:60,
    from ../../include/QtGui/private/qfontengine_p.h:1,
    from gl2paintengineex/qpaintengineex_opengl2_p.h:63,
    from qgl.cpp:71:
    ../../include/QtCore/../../src/corelib/io/qurl.h:70: error: expected identifier before numeric constant
    ../../include/QtCore/../../src/corelib/io/qurl.h:70: error: expected ‘}’ before numeric constant
    ../../include/QtCore/../../src/corelib/io/qurl.h:70: error: expected unqualified-id before numeric constant

    I read, that the problem is because of the defined constant None in an X11-header. In qcoreevents.h, which shows me the same error, is an comment that should be the reason and I should include the Qt headers before the X ones, but that did not work. And that should not be the solution because its Qt itself.

    Hope someone can give me some help.
    Kind regards,

  • Hello guys,

    I solved the problem with the -DMESA_EGL_NO_X11_HEADERS
    flag while running configure. So it was a problem with defined symbols by X11.

  • Hi @evotion

    What is the board [ I mean the H/W Platfom ] , that you are working on?

  • I've the same problem, but I cannot solve it with -DMESA_EGL_NO_X11_HEADERS.
    I'm not using mesa driver.

    Any ideas?

Log in to reply