Problems when i try to install qt3d



  • Hi !! , I tried to install QT3D on a new installation of ubuntu. I followed the directions via this link: http://qt-project.org/wiki/Building-Qt-5-from-Git

    And unfortunately I have a problem on my system with this step:

    make install

    My console:
    make [3]: Entering directory "/ home / tev / QT5 / qtwebkit / Source"
    make [3]: *** No rule to make target "/home/tev/qt5/qtwebkit/Source/WebKit2//libWebKit2.a" necessary to "/ home / tev / QT5 / qtbase / lib / libQt5WebKit .so.5.4.1 ". Off.
    make [3]: Leaving directory "/ home / tev / QT5 / qtwebkit / Source"
    make [2]: *** [sub-api-pri-install_subtargets-ordered] Error 2
    make [2]: Leaving directory "/ home / tev / QT5 / qtwebkit / Source"
    make [1]: *** [sub-Source-QtWebKit-pro-install_subtargets-ordered] Error 2
    make [1]: Leaving directory "/ home / tev / QT5 / qtwebkit"
    make: *** [Module-qtwebkit-install_subtargets] Error 2

    Where is the problem during installation?
    Can be here? : /home/tev/qt5/qtwebkit/Source/WebKit2//libWebKit2.a

    With the dual ---> //

    Thank you for your reply !!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Might be a silly question but, why do you build Qt from scratch ? If you want to only build the Qt3D module you don't have to rebuild Qt completely.



  • Thank you for the welcome SGaist :)

    I have done just followed the steps in the webpage mentioned in my first post :)


  • Lifetime Qt Champion

    That's why I'm asking you: do you really want to build Qt completely ? You should be able to add that new module by just calling the classic qmake -> make -> make install



  • In fact I have reinstall QT5 (and ubuntu ...) to install qt3d .... except that I follow every tutorial and nothing works ...

    And I thought reinstalling by following the links given in my first post, all would works

    seen that it does not walk by following the tutorial. I downloaded qt3d separately and I tried to comiler with Qt Creator
    When I try to compile with QT 5.4.1 under qt creator. This puts me "Qt3D requires Qt Declarative"

    What tutorial offers qt3D works?

    Thanks for your help :)



  • I found the solution to my problem.
    I install QT 4.8. Then qmake -> Make-> make install (with sudo).
    Compiled qt3D with qmake /usr/local/Trolltech/Qt-4.8.7/bin/qmake qt3d.pro
    make -> make install (with sudo)

    Do not forget to qt creator opens with the terminal and sudo.

    Voila :)


  • Lifetime Qt Champion

    It should work as well with Qt 5. Didn't you use the online installer for Qt 5 ? Or even your distribution's Qt 5 ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.