Android deployment on Qt 5.4.0 and Qt Creator 3.3.0



  • Hi, as the title says, I'm on Linux 64bit, Qt 5.4.0 RC and I'm using the bundled Qt Creator 3.3.0 RC
    I collected as much information as I could and configured Creator to deploy on Android.
    I can successfully deploy the examples (I tried with Calqlatr) but on a more complex application I found a few things that I don't understand.

    First of all, according to "Deploying Applications to Android Devices":https://qt-project.org/doc/qtcreator-3.2/creator-deploying-android.html I should see "these deployment options":https://qt-project.org/doc/qtcreator-3.2/images/qtcreator-android-deploy-configurations.png
    Unfortunately what I see in my system is totally different: http://pbrd.co/1wbII5b
    Am I missing something or have I just found a bug ?

    Secondly (and depending on not being able to see the full deployment settings) I am not able to figure out how to correctly load a shared library from within the APK. The library is actually bundled in the APK but when I launch the app in my tablet it closes and debug messages say it cannot find the library which is actually there in /libs/armeabi-v7a

    A similar thing happens for all the other resources of my application (html files, xml templates, etc). They are correctly installed in the android build folder, but they don't go into the APK.
    How do I specify where to add arbitrary resources ?

    Any help is appreciated, thanks



  • Update: after a few more tries, it turned out that:

    • my library was not loaded cause of missing QtScript dependency in the main app. Adding it solved the runtime load

    • extra contents must be placed in "/assets" and loaded via QFile("assets:/...")

    Still I don't understand why I don't have the full deployment options in Qt Creator


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.