Important: Please read the Qt Code of Conduct -

Project error: unknown module QT: webkitwidgets

  • Hi,
    I found few posts about this problem and my problem is not related to compilation of webkit.
    I have QT compiled with both Qtwebkit and Qtwebkitwidgets. Now I am trying to use them in my project file like
    QT += webkit and QT += Qtwebkitwidgets.

    But I am getting above error:

    Now I changed the project file as follows:

    Qt_MODULES += webkitwidgets
    Qt_MODULES += webkit

    Now this time it generated the Makefile but when I am trying to use #include <QtWebKitWidgets> and #include <QtWebKit> in my application it says No such file or directory.


  • Moderators

    QT = core gui widgets webkit webkitwidgets

    Do not put that "Qt" in front of "webkitwidgets".

  • No I am not using QtWebkitwidget or Qtwebkit.

    QT = webkit webkitwidgets.

    Project error: Unknown modules in QT: webkit webkitwidgets

    Then I tried:
    qmake -d

    It gave me following:

    DEBUG 1: qt_src/qtbase/mkspecs/features/qt_functions.prf:172 : calling built in error ("unknown module in QT: webkit webkitwidgets)

    Project error: Unknown module in QT: webkit webkitwidgets

    As I said, I have both compiled and their libraries were in their respective folders and not at qbase/lib folder.

    Does this give some clue?

  • Moderators

    They should have been copied to qtbase. Maybe you should run make install?

  • hi thanks for your reply.

    I moved my application folder within the qt_src folder and ran the similar command: qmake -o Makefile and it worked without any problem.
    I am not getting this stringent behaviour?

    Now fell into another issue: when I'm trying to deploy this test application, I copied my executable at the /bin directory and all the qt libraries at the /lib directory. I also put my plugins at /plugins/platform and fonts at /lib/fonts and now I am trying to run the application as below:

    export LD_LIBRARY_PATH=./lib
    export QT_QPA_FONTDIR=./lib/fonts
    export QT_QPA_PLATFORM_PLUGIN_PATH=/plugins/platforms

    and running the application:

    ./qt_test -platform linuxfb -display fb:/dev/fb3

    Now it says: This application failed to start because it could not find or load the Qt platform plugin "linuxfb".

    I am wondering why it is giving this error, Unfortunate thing is I managed to run the application 2 days before and after doing some changes it is not running now.

    Is this something related to how I created my makefile and generated the executable, because I am creating executable at one place and copying our to my target.


  • Lifetime Qt Champion


    @export QT_QPA_PLATFORM_PLUGIN_PATH=/plugins/platforms@

    I might be wrong but aren't your missing a . before /plugins ?

  • no this is not an issue (it's typing error). Is my command:

    ./qt_test -platform linuxfb -display fb:/dev/fb3


Log in to reply