PNG image for Symbian app icon



  • It seems SVG engine on Symbian has a bug in rendering embedded PNG, which makes it appearing with some unexpected lines. I see the same issue when opening the same SVG file from the file manager.

    Does anyone have a suggestion to use a raster image with transparency for Symbian app icon? Vectorizing by tracing the bitmap is not an option for me due to time constraint and the complexity of the icon design...



  • Hi,

    I also had some trouble with converting icons to SVG in the past. Have you tried using Inkscape?

    I assume that you have already done this but anyway just to mention: once you have your svg added it to the symbian section of the pro file:
    @ICON = appicon.svg@

    Regards,
    Leon



  • Yes, I used Inkscape, and I don't think there's anything wrong with .pro file.

    I did some further investigation, I could reproduce the issue only with some specific PNG images. Also, if I change the width and height of the embedded image to smaller than the overall svg element, it renders fine on Symbian.

    So, I was able to solve the issue but it's still unclear why it happened. I suspect there's a bug in S60's SVG rendering of an embedded image that occurs only in some rare circumstances...

    By the way, Qt should provide a tool to be able to use the same icon image for all the platform. This is just so cumbersome that one has to provide a bitmap image for most platforms and a vector image for Symbian.



  • [quote author="moo1" date="1301955349"]
    So, I was able to solve the issue but it's still unclear why it happened. I suspect there's a bug in S60's SVG rendering of an embedded image that occurs only in some rare circumstances...
    [/quote]

    I am glad that you have solved the issue. But only because my curiosity I would like to ask on which version of Symbian have tried it? If you suspect a bug you can also try it on different devices and Symbian versions using Nokia Remote Device Access.



  • if you think there is a problem, file a bug in http://bugreports.qt.nokia.com/secure/Dashboard.jspa
    Use the label qt-base-symbian-rnd, it will appear in symbian team backlog. We will check it. Remember to provide the need svg file to reproduce the problem.



  • I also converted a PNG image to SVGTiny with image2svg app. When I run the app with Creator the icon is messed up but when I copied the .sis to phone and installed it there it seemed to work fine.




Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.