Error: cannot find -lGL

  • I have installed Qt IDE with Qt Online Installer for Linux 32-bit (23 MB). I have a problem, then I am compilled simple qt widget application :
    :-1: error: cannot find -lGL'
    :-1: error: collect2: error: ld returned 1 exit status

    Help me please to solve this problem.

  • Moderators


    You need to install OpenGL development libraries. On Ubuntu, the package is libgl1-mesa-dev.

    P.S. This is a very common topic -- Google would have helped you find the solution quickly.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.