Missing QtAndroidBluetooth-bundled.jar



  • Hi!

    I built QT 5.3.2 and QT 5.4.0-beta for Android/ARM and wanted to create an apk with bluetooth. If I use the precompiled android edition from downloads it will work without any problems.

    But if I use a self-compiled QT it won't find a "QtAndroidBluetooth-bundled.jar" during apk creation. File libQt5Bluetooth.so exists and other .jar files, too. But no QtAndroidBluetooth-bundled.jar....

    Any hints for me?

    @Copying 42 dependencies from Qt into package.
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Core.so
    -- Copied [...]/dist/libs/QtAndroid-bundled.jar
    -- Copied [...]/dist/libs/QtAndroidAccessibility-bundled.jar
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5AndroidExtras.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Gui.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_platforms_android_libqtforandroid.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_platforms_libqeglfs.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_platforms_libqminimal.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_platforms_libqminimalegl.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_platforms_libqoffscreen.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_generic_libqevdevkeyboardplugin.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_generic_libqevdevmouseplugin.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_generic_libqevdevtabletplugin.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_generic_libqevdevtouchplugin.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_iconengines_libqsvgicon.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqdds.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqgif.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqicns.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqico.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqjp2.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqjpeg.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqmng.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqsvg.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqtga.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqtiff.so
    -- Copied [...]/dist/libs/armeabi-v7a/libplugins_imageformats_libqwbmp.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Widgets.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Svg.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5PrintSupport.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Concurrent.so
    -- Copied [...]/dist/libs/armeabi-v7a/libQt5Bluetooth.so
    Source Qt file does not exist: [...]/dist/libs/android_arm/dist/jar/QtAndroidBluetooth-bundled.jar.
    @

    @$ ll [...]/dist/libs/android_arm/dist/jar

    -rwxr-xr-x 1 user user 7,2K 6. Nov 16:02 QtAndroidAccessibility-bundled.jar
    -rwxr-xr-x 1 user user 4,6K 6. Nov 16:02 QtAndroidAccessibility.jar
    -rwxr-xr-x 1 user user 3,0K 6. Nov 16:02 QtAndroidBearer-bundled.jar
    -rwxr-xr-x 1 user user 1,6K 6. Nov 16:02 QtAndroidBearer.jar
    -rwxr-xr-x 1 user user 83K 6. Nov 16:02 QtAndroid-bundled.jar
    -rwxr-xr-x 1 user user 44K 6. Nov 16:02 QtAndroid.jar
    -rwxr-xr-x 1 user user 3,4K 6. Nov 16:03 QtSensors-bundled.jar
    -rwxr-xr-x 1 user user 2,7K 6. Nov 16:03 QtSensors.jar
    @



  • Well, seems to be working now....

    Enviroment variable PATH used OpenJDK 1.7 and JAVA_HOME used Oracle JDK 1.8. I switched JAVA_HOME to OpenJDK 1.7 and now I get the .jar!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.