Important: Please read the Qt Code of Conduct -

Qt 5.2.0 no compiler definited

  • So basicly I had installed the qt 5.2.0
    I had previously installed visual studio 2013

    I just wana build an app but id doesnt detect a suitable compiler

    This is how my kit looks

    ! Text)!

    and this is how my compliers look


    Basicly I can't select (or add) a compiler to the kit, in the kits tab,
    the select box comes available after i add/clone a compiler in the compilers tab.

    Anyway I tried compiling it with the 3 available compilers and its not working,
    I tried to add mingw to the compilers and try to do it with it but it didnt work.

    I did it like


    I tried specyfing files for the compilator like :

    I get tons of errors,

    I installed mingw from the installer on

    Any clues what should I do ?
    Installing visual 2012 will help?

    Last time I was developing apps for qt 5.2.0 I had vs2013 and it runned smoothly

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Indeed you have to install Visual Studio 2012. You can't mix and match compilers and library versions on Windows. The compilers are not compatible one with the other.

Log in to reply