Build old project with old clang compiler version



  • Hi,

    Motivation: As part of my daily work, I need from time to time, to solve issues on old version of my application.
    Issue: I have a bug which I need to fix on old version. This version was built and compiled with QT 4.7.4 ( QT Creator 2.4.1).
    I have QT 5.2 on my Mac machine (Os version: 10.9.3, Clang: 5.1 LLVM 3.4svn) so I installed QtSDK (4.7.4) as well.

    No matter what I tried to do, I could find a way to install old version of Clang compiler and configure QTCreator to use it.
    I know I need CLang 4.1 LLVM 3.1svn but QTCreator 2.4.1 (for Qt 4.7.4) cannot find it or use it .

    The bottom line: How can I have several versions of Clang compiler on my Mac and how can I set QTCreator to use specific compiler?
    I would expect it to be simple just as I have Visual Studio 2005, 2010 and 2012 on my one Windows platform and each of which uses it's own relevant compiler.

    Thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK you'll need to install the corresponding old version of Xcode in order to do that.

    Apple doesn't work like Microsoft for that, new version of Xcode replaces the old one while you can still compile software that will run on older version (with the limitations that might come with it)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.