Important: Please read the Qt Code of Conduct -

[Solved] Qt everywhere 5.3.2 source compile failure on beaglebone black with -DQT_NO_DEBUG_OUTPUT

  • I'm planning on developing beaglebone debian 7.6 applications on a beaglebone black using Qt 5.3.2
    I compiled the qt everywhere 5.3.2 open source library fine on the beaglebone with the following configure options

    configure -v -opensource -confirm-license -prefix /usr/local/qt-5.3.2 -no-largefile -qt-zlib -qt-libpng -qt-libjpeg -no-nis -no-cups -opengl es2 -qt-xcb -qt-freetype -qt-xkbcommon -no-kms -v

    And it compiles and works fine.
    However, the terminal is overrun with debugging messages and it runs very slow.
    I attempted to turn off the debugging messages using the option:

    configure -v -opensource -confirm-license -prefix /usr/local/qt-5.3.2 -no-largefile -qt-zlib -qt-libpng -qt-libjpeg -no-nis -no-cups -opengl es2 -qt-xcb -qt-freetype -qt-xkbcommon -no-kms -v -DQT_NO_DEBUG_OUTPUT -DQT_NO_WARNING_OUTPUT

    Now it compiles until it reaches qtdeclarative/src/quick/scenegraph/coreapi/qsgbatchrenderer.cpp:

    src/qtdeclarative/src/quick/scenegraph/coreapi/qsgbatchrenderer.cpp:256:20: error: expected primary-expression before 'while'

    It bombs out trying to compile the line

        QDebug d = qDebug();

    I'm compiling with gcc version 4.6.3-14

    Any ideas on how to get the compile to work?
    Or another way to disable debug and warning console messages?

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    There's a patch pending for 5.4 for that problem.

    In between you can comment the offending code since it's all debugging related and you don't seem interested

  • Commenting out the code that uses QDebug in a manner that throws exceptions when debug messages are turned off works.
    I successfully compiled the code with -DQT_NO_DEBUG_OUTPUT -DQT_NO_WARNING_OUTPUT.
    It runs without messages output to the console window.

  • Lifetime Qt Champion

    Patch got in, so you'll be fine when 5.4 RC comes out

Log in to reply