[SOLVED] Deploy QtQuick on OS X Yosemite it doesn't work



  • hi guys...

    I have a project and I try to make a deploy on other OS X computers.

    I'm using macdeployqt application from qt tools and i don't have any error when i set -verbose=3

    when i generate a dmg file (using -dmg option) and I try to run my applicaion in other mac which doesn't have installed qt the application crach it...

    My project is a desktop application using qtquick

    i don't know how much information i have to post here, so if you can help me and if I have to post other info just tell me please

    best regards

    freddy



  • Hi freddy311082,

    It's happened because the macdeployqt tool has a bug with frameworks. If you try to open you app bundle and try to watch the frameworks list you don't find any Info.plist files in frameworks folders. That's why others mac can't load your app.
    Also you need Apple Developer certificates. You must have two certificate:

    1. 3rd Party Mac Developer Application: <developer name> needs for certification of your application.
    2. 3rd Party Mac Developer Installer: <developer name> needs for create package file and then send it to Apple Mac App Store.

    I've started the application to create the correct bundle but still have a few problem. For more information see "this thread.":http://qt-project.org/forums/viewthread/48391/



  • Hi shav... thank for answer and for your contribution to the Qt community my friend.

    1.- I have some problems with the application. I font have any certificates from Mac, so, the lineEdit for each certificate is not enabled
    2.- I have think that I don't need to add my QML folder because is in my resource... it's that true ??

    well bro, the application keep running after I click the Deploy button and never finish...

    best regards



  • Sorry, the application still in development so you can have some bugs :).

    In your case you not need to set certificates. All you need to select you application bundle path, QML files (if your app using plugins of QML) and path to your Qt install folder. The path to your Qt folder must looks like:
    @
    <full_path_to_Qt_root_folder>/5.3/clang_64
    @

    Thats it!

    P.S. Application needs a few time. Please watch to spinner on the bottom left of app screen.



  • yes my friend. the spinner is working, the application give me this output:
    @Start working....
    Call /Applications/Qt5.3.2/5.3/clang_64/bin/macdeployqt with result: {}
    Call ls with result: {total 5400
    drwxr-xr-x 19 freddymartinezgarcia admin 646 Oct 19 16:37 .
    drwxr-xr-x 8 freddymartinezgarcia admin 272 Oct 19 16:37 ..
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtConcurrent.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtCore.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtGui.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtNetwork.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtPrintSupport.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtQml.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtQuick.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtTest.framework
    drwxr-xr-x 4 freddymartinezgarcia admin 136 Oct 19 16:37 QtWidgets.framework
    -rw------- 1 freddymartinezgarcia admin 86340 Oct 19 16:37 libboost_filesystem-mt.dylib
    -rw------- 1 freddymartinezgarcia admin 86340 Oct 19 16:37 libboost_filesystem.dylib
    -rw------- 1 freddymartinezgarcia admin 384828 Oct 19 16:37 libboost_program_options-mt.dylib
    -rw------- 1 freddymartinezgarcia admin 856584 Oct 19 16:37 libboost_regex.dylib
    -rw------- 1 freddymartinezgarcia admin 19436 Oct 19 16:37 libboost_system-mt.dylib
    -rw------- 1 freddymartinezgarcia admin 19436 Oct 19 16:37 libboost_system.dylib
    -rw------- 1 freddymartinezgarcia admin 100124 Oct 19 16:37 libboost_thread-mt.dylib
    -rw------- 1 freddymartinezgarcia admin 1193612 Oct 19 16:37 libmongoclient.dylib
    }
    Call sh with result: {warning: no debug symbols in executable (-arch x86_64)
    }@

    and nothing more happen. The aplication generate a adviser.app.dSYM file, but nothing more.

    how much time i must wait ??

    i vae a macbook pro with a core i7 2/6 GHz and 16 Gb of RAM DDR3 1600 MGz

    best regards and thank you very much



  • Sorry, I've found the bug.

    The application finished job! Try your app on Mac which doesn't has Qt. The bug is application doesn't sent finished signal to GUI thats why you see spinner.

    I've fixed this bug and commit new version to repo and my site. If you want please use "git repo"https://github.com/dshav/qtappmacdeploy: to get new build.

    If you found any issues please post it to "thread":http://qt-project.org/forums/viewthread/48391.



  • Thank you very much my friend. It's work PRFECTLY !!!

    awesome work

    regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.