Building the Qt540 beta from source on win32.



  • Good day,

    I'm not sure if this is the right spot for a beta version question but for interest I downloaded the source of the Qt5.4 beta and tried to build it like I would normally do for released version but it seems that the qtbase/configure.exe is missing. This is running on Windows 7 64bit OS with VS2010. I wanted to build the 32bit version. Should it be there or am I doing something wrong? and yes I could just download a pre-built version to continue on but was curious.

    Thanks for any info.
    m


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Where did you get the sources ?



  • I just download it from the link on 5.4 beta announcement. At http://download.qt-project.org/development_releases/qt/5.4/5.4.0-beta/single/

    and I downloaded the file: qt-everywhere-opensource-src-5.4.0-beta.7z



  • Hello everybody,

    same problem here!
    No matter which source I download (7z, zip, tar.gz...), the configure.exe (I assume in "qtbase") is simply missing.

    We had the same problem some days ago, when we tried to build Qt from a zip file.
    We had repacked the source files, because cmake wouldn't unzip the downloaded archive, complaining about a problem with symlinks (I'm working on Win7).
    In our repacked zip somehow the configure.exe went missing (in fact it already went missing during the first decompression)... after a new try using 7zip, the archive was OK (however, it still didn't work with cmake).

    Maybe there has been a problem packing the files for the beta release, too?
    (Maybe it even has to do with the symlinks?)


  • Lifetime Qt Champion

    AFAIK, on windows, you should use the zip file.

    An alternative if you want to build Qt, is to clone it and checkout the 5.4 branch



  • Well, it doesn't matter what kind of archive I use, the .exe is always missing... (besides, all packages should have the same content, shouldn't they?)
    However, I will give the checkout a try as soon as I get back to work
    Thanks for your reply!



  • Ok, the version I checked out from gitorious can be configured, but it turned out to be version 5.3.3 ... eventough I'm quite sure I told him to clone the 5.4 version... but I'm not exactly what you would call a git expert...

    After that I downloaded the .zip archive containing the Qt5.4beta source code again... the problem remains:

    the command "[...] \qt-everywhere-opensource-src-5.4.0-beta\qtbase\configure.exe" could not be found


  • Lifetime Qt Champion

    There's not only the content but also the line endings that matters.

    You clone a repository not a branch, once cloned you need to checkout 5.4



  • As a quick experiment I copied the configure.exe out of a released 5.3 source disto and dropped it into the 5.4 disto. While I can run configure now it quickly says something about not having a GPL'd license and pukes.



  • Ok, I uploaded an image comparing the content of two recently downloaded .zip files of the source code - one containing the alpha, the other containing the beta.
    We are inside the "qtbase" folder:

    !https://farm6.staticflickr.com/5604/15603441731_60b3569027_o.png!

    In the beta folder, the "configure.exe" is simply missing... there might be an obscure workaround, but to be honest, I think a re-upload would be the best solution?


  • Lifetime Qt Champion

    I'd first call configure.bat, IIRC it should generate configure.exe



  • Ok, since I had some spare time, I went through everything one more time.

    Step by step:

    I used a different PC, installed Perl and Python (just to be sure), set the PATH variable accordingly and downloaded the zipped source code of the alpha and the beta release.

    I unzipped both using the same tool and folder-strucutre, created new folders for the configurations. I opened two windows shells and changed into the two empty folders for the configurations.

    After that i typed the identical configuration command into both shells:
    @..\qt-everywhere-opensource-src-5.4.0-[...]\configure -opensource -debug-and-release -confirm-license -skip qtwebkit -skip qtwebengine -mp@

    Same result as always: the alpha will configure correctly, while the beta will fail right at the beginning

    !https://farm6.staticflickr.com/5610/15435436847_a92cfeb64a_o.png!

    After that I followed your hint with the configure.bat and took a look at the script: the same for both files (alpha and beta). If I understand correctly the configure.bat will (after some tests) change into the qtbase directory and call the configure.bat there.

    Except for the copyright this file is identical in both releases, too.
    One of the first things done by the batch script ist
    @if not exist %QTSRC%.gitignore goto sconf@

    Since I can't find the .gitignore file anywhere, I assume the goto will be executed und we will end up in these lines:
    @
    :sconf
    %QTSRC%\configure.exe %*
    :exit
    @

    But since the configure.exe doesn't exist, the configuration will fail!

    Did I miss out a step? Where would the configure.exe be created?


  • Lifetime Qt Champion

    configure.bat should have but "here":https://bugreports.qt-project.org/browse/QTBUG-42069 you have the workaround



  • Thanks a lot! This is what I've been looking for!
    Eventhough I'm not too happy with using that workaround, I think it will do. After all it still is just the beta release...

    Over and out


  • Lifetime Qt Champion

    Well, at least it's just a glitch, would have been worse if configure.exe was out of reach :D

    Anyway, since it's working now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)



  • Well, since I don't own the thread, I can't do so... :/


  • Lifetime Qt Champion

    I forgot that you jumped in :-D


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.