Konfiguracja GIT dla Qt Creator



  • Witam.
    Skonfigurowałem aplikację GIT do działania ze stroną Bitbucket.org.
    Utworzyłem klucze SSH i połączyłem ze stroną.
    W GIT Bash komenda ssh -T git@bitbucket.org działa i podaje właściwego użytkownika.
    W Atlassian SourceTree też działa (utworzyłem w nim repozytorium i wysłałem na serwer).

    Mam kłopot z konfiguracją Qt Creatora z GIT'em. Do zmiennej PATH (w ustawieniach GIT) dałem ścieżkę do katalogu Bin GIT'a.

    Przy próbie utworzenia nowego projektu z Systemu Kontroli Wersji, jak pobieram gałęzie, to czekam dosyć długo, potem dostaję informację, że aplikacja GIT nie odpowiada i czy ma ją zakończyć.
    Z tego co wyszukałem, problem jest z loginem i hasłem - sam Creator o to nie pyta. Ściągnąłem z Sourceforge.net aplikację win_ssh_askpass i podałem do ścieżki w ustawieniach Creatora. Dalej nic. Gdzieś tam czytałem, że ta opcja jest dostępna pod Linuksa, więc pewnie ta aplikacja mi się nie przyda ?

    Jak zmusić Qt Creator do działania ?



  • przy generowaniu klucza podawałeś hasło ??
    jeśli tem to spróbuje wygenerować klucz z pustym hasłem.
    "Link":http://www.cieslak.info.pl/index.php/87-qt-creator-i-git-konfiguracja-cz1



  • AAA no popatrz.

    Ja wpisywałem adres HTTPS, a nie SSH.
    Drugie - to miałem hasło na SSH, niestety trzeba było za każdym razem je wpisywać. Szkoda, nie można tego ominąć jakoś ?

    W trzeciej części tego kursu jest chyba błąd, bo tam jest skopiowany link HTTPS, a nie SSH. W GIT zawsze mnie pyta o hasło, więc przy Qt też powinno ?

    Ok, już działa. Pobrałem pliki i wrzuciłem zmiany na serwer. Trochę to skomplikowane. W sensie, że trzeba najpierw je wrzucić (skrót ALT-C/G) a potem przepchnąć (tutaj już skrótu nie ma :( ).

    Nie znalazłem dokładnego opisu ani też przykładów co robią poszczególne opcje i jak pisać skrypty dla zakładek "Git" oraz "Ogólne".

    Ale ok, jeszcze nad tym popracuje i jak znajdę dodatkowe pytania, to napiszę.

    Pozdrawiam.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.