{Solved} QTableWidget signal 'itemClicked' doesnt fire at all



  • Hi All,

    We are developing an application where we generate several QTableWidget objects dynamically and show them on the screen. The problem is when I connect to 'itemClicked' signal of the QTableWidget to my public slot, it doesn't get fire at all when I manually click on any of the QTableWidgetItem.

    I even tried itemActivated, itemPressed signals, but none of them works.

    However, signal 'currentItemChanged' gets fired properly.

    am I missing something?

    Regards,
    Vrushali



  • hi,

    Do you setup the QApplication correctly?

    @
    #include "mainwindow.h"
    #include <QApplication>
    int main(int argc, char *argv[]) {
    QApplication a(argc, argv);//<--- important
    MainWindow w;
    w.show();
    return a.exec(); //<--- important
    }
    @

    2nd: do you use QTableWidget in a separate event loop (QObject::moveToThread)?



  • Hi,

    I restarted the Qt Creator and system and issue seems to be resolved...

    Thanks for your help !



  • Hi.
    Please add {SOLVED} before the title if your problem is solved.
    So other members can notify that solution has been found.
    Thanks.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.