QT 4.4.1 build errors on RHEL 6.3 from source



  • I am having trouble building QT 4.4.1 on RHEL 6.3 from source. I downloaded qt-x11-opensource-src-4.4.1, did the ./configure command with no options, then the make command.

    The make fails. I am seeing errors like ../../include/QtNetwork/../../src/network/kernel/qurlinfo.h:405: error: 'd' was not declared in this scope

    Any thoughts on why this won't compile out of the box?

    gcc version is 4.4.6

    I was originally trying to use qt 5.1.1, but I ran across too many errors with that runing with the version of gcc that I have. So I decided to drop back to an old version, but now I am having the issues listed above.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Before going any further, did you check the Qt version available on your RHEL distribution ?



  • SGaist,

    Thats a great idea. RHEL 6.3 comes with Qt 4.6.2. That seems to work just fine.

    Still not sure why Qt 4.4.1 doesn't build correctly though.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.