Important: Please read the Qt Code of Conduct -

Qt Creator cannot detect gcc compiler

  • Hello,
    I recently installed the new Ubuntu version 14.04 and tried to get the Qt version 5.3.2 to work. But after installing Qt (i tried online and offline installer) i got the error message that qt creator needs a compiler to create the project. Then i saw in the kit settings that qt didn't set a gcc compiler automatically. I knew that ubuntu brings a gcc compiler with it so i added the compiler by myself. After this, a red icon in the kit settings, between my qt version, had the following error message: The compiler "GCC"(x86-linux-generic-elf-64bit) cannot create code for Qt-version "Qt 5.3 GCC 32bit"(x86-linux-generic-elf-32bit). My compiler path is "/usr/bin/gcc". I tried to find any solution in the internet, but couldn't find one.
    I am very thankful for every answer that helps and sorry for grammar mistakes, english is not my native language.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you do that by hand or by installing the buildessential (or build-essential) package ?

  • Hi and thanks,
    What do you exactly mean? I downloaded the .run file from and executed it, so the installation guide poped up. First i tried the Qt Online Installer for Linux(32 bit) and then the offline installer. Both didnt't work. I'm also running ubuntu 32 bit. If you mean adding the gcc compiler then yes i did that by hand in the compiler settings of qt creator,

  • Moderators


    Ubuntu includes the C compiler by default, but not the C++ compiler. You need to install g++.

    You also probably need to install OpenGL libraries: libglu1-mesa-dev

  • Hey,
    Thank you very much. I needed both to get it to work. Everything works fine now :)

Log in to reply