Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installation error "Hash verification while downloading failed"



  • I downloaded the qt-opensource-linux-x86-1.6.0-5-online.run (32 bit) and ran it.
    QT Setup Wizard appeared and during installation, I am getting "Hash verification while downloading failed.
    it stuck when downloading the "1.6.0-5installerbase-linux-x86.7z" for component:Maintenance Tools
    I tried many times and I am getting the same error.

    Any idea on what do I need to do?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You might be using a fault mirror. -However, are you tied to that very old SDK ?-



  • I download the qt-opensource-linux-x86-1.6.0-5-online.run from www.qt.io/downloads QT online installer for linux 32-bit.

    After I ran ./qt-opensource-linux-x86-1.6.0-5-online.run, a wizard appeared and start downloading the packages. I don't have any control of that!


  • Lifetime Qt Champion

    Sorry, I've mixed the numbering with an even older version. You have the correct on one.

    Have a look at this "tool":https://github.com/JKSH/QtSdkRepoChooser It might help



  • I found a larger package to download which was
    Qt 5.3.2 for Linux 32-bit (449 MB) (Info) and managed to install it without error.

    in the Application/Programming menu, I have a QT Creator (opensource). But when I click on it nothing happening!

    Itried manually to run the qtcreator but I am getting the following errors;

    [root@rpcztc bin]# ./qtcreator
    Failed to load core: /opt/Qt5.3.2/Tools/QtCreator/lib/qtcreator/plugins/libCore.so: Cannot load library /opt/Qt5.3.2/Tools/QtCreator/lib/qtcreator/plugins/libCore.so: (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /opt/Qt5.3.2/Tools/QtCreator/lib/qtcreator/plugins/libCore.so))

    I already used yum install mesa-libGL and yum install mesa-libGL-devel


  • Lifetime Qt Champion

    What's your distribution ?



  • Centos 6.4 32-bit


  • Lifetime Qt Champion

    IIRC, it's a RedHat derivative and you might have an older version of libstdc++ on your system. So you should either update it or build Qt by hand


Log in to reply