Important: Please read the Qt Code of Conduct -

[SOLVED]FrameBuffer Issue while running the Qt application

  • Hi all,

    I using customized board similar to that of Beagleboard-xm, in which Ubuntu 12.10 is running on it.

    I have build the Qt4.8.6 source using Linaro Toolchain with the support of -qt-gfx-linuxfb.
    I have even transferred all the libraries to the board and I have set the required environment paths also.

    But when I run my application on the board,
    Eg: ./test -qws

    The following error pops up:
    QScreenLinuxFb::connect: Permission denied
    Error opening framebufferdevice /dev/fb0

    I tried by running as sudo but stiil no success I got the following error:
    Qt for Embedded Linux data directory is not owned by user 0: /tmp/qtembedded-0

    Can anyone please help me for solving this issue I have stuck in this part and I am unable to run Qt application.

  • Hi,

    Did you compile Qt with some Graphics Driver? For example, in Buildroot you can choose a driver like: Linux Framebuffer, QtVirtual Frame Buffer, VNC, etc... If you didn't compile with a Graphic Driver may happen some trouble.

    Try to check this.

  • Hi,
    Thank you.

    Yes I have compiled Qt source to choose Linux framebuffer by giving the option -qt-gfx-linuxfb.

  • Lifetime Qt Champion


    First thing, check the rights of /dev/fb0 and correct your current user groups to include what is needed.

    For the second problem, you have to delete /tmp/qtembedded-0 first, because it currently belongs to the user you used when starting your application the first time

  • Yes I will tryout both the options.
    Thank you.

  • Hi,

    I resolved my issue using the second suggestion you gave.
    Thank you. :)

  • Lifetime Qt Champion

    You're welcome !

    Since you have your application running, please update the thread title prepending [solved] so other forum users may know a solution has been found :)

Log in to reply