Important: Please read the Qt Code of Conduct -

Static configuration failing on ubuntu

  • I first did a standard installation using 64 bit .run file on my ubuntu.
    Then since I wanted to deploy on server environments without qt, I wanted to build a static framework too.
    I downloaded the tar.gz file but on tar -xvf it fails with errors.
    Has anyone previously noticed this? It takes about 6 hours to download in the first place hence my question before I restart a download.

    Is there a faster way out there for qt downloads?

  • Lifetime Qt Champion


    You can try e.g. clone Qt from git

  • Yes, Download from mirror sites is both faster and the new file didn't give any errors. Download time reduced from 6 hours -> 45 mins when I downloaded from a mirror in asia.

  • Lifetime Qt Champion

    Nice, so your problem is solved ?

    If so please update the thread title prepending [solved] so other forum users may know a solution has been found :)

  • Not solved completely.
    I did static configure, make and make install.
    Afterwards I opened the example clocks project.
    Added Confi += static and tried to deploy it to linux box. It still gave me the error not found.

    How can I check that static install worked?
    Should i launch the static configure qt seperately? IF so how?
    ANything else I am missing?

  • Lifetime Qt Champion

    Indeed you need to build Qt statically and it's best to store it in a different folder that the dynamic version. If the build's successful then you should not have any so files.

    You must also add that version of Qt to Qt Creator and create a kit using it.

Log in to reply