Weirdly opening Qt application on BeagleBone Black

  • Hello guys,

    I've cross-compiled a couple basic Qt applications to a BeagleBone Black (running Angstrom) using the following tutorial

    When i execute the app ./InitialGUITest -qws nothing at all happens.
    I've realized i need to press ctrl+alt+f2 to be able to see my application running, and then i cannot get back to the my default environment (ctrl+alt+BKSPACE or ctrl+atl+f1->7).
    Is this meant to execute like this?

    Also im using a touch-screen and the Qt app does not respond to the touch, although i can see a cursor visible AND the touchscreen does work in the default enviroment.
    How can i tell the app to use my touchscreen?

    Sorry if im a little vague or asking common-knowledge questions. Im new to linux and Qt.

  • Did you set the environment variables correctly?

    If you are using Qt with Tslib driver for TouchScreen you can set your variables like this:

    export TSLIB_FBDEVICE=/dev/fb0
    export TSLIB_TSDEVICE=/dev/input/event1
    export TSLIB_CALIBFILE=/etc/pointercal
    export QWS_MOUSE_PROTO=tslib:/dev/input/event1

    This will set your application to use touchscreen and display device if your driver was compiled correctly.


  • Thanks for the reply mate.

    All fixed. ended up being a problem with my configure.
    I needed to add -qt-mouse-tslib

    Any ideas on how i can incorprate the GPIO's of my BBB with the Qt app?

  • The easiest way to use them is by QProcess. You can run commands like "cat" for reading and "echo" + ">>" to setting values. But this will work just for Linux.

    Another way, to work in more platoforms, you can use QFile and read/write functions to read GPIO file.

    Dont forget to enable kernel and/or buildroot to create gpio files on "/sys/class/gpio", if you are using linux.


  • I had also the same issue, please read the below blog
    This might help you

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.