Online installer fails with insufficient temp space on Linux



  • Trying to install on Linux (Debian, Wheezy, 64-bit) but the online installer complains about insufficient space in the temporary directory. How can I specify an alternative temp directory (on a different filesystem) ?



  • Well, I also use Debian Wheezy 64-bit, but I rather downloaded the ofline installer.

    Is the insufficient space remark limited to the temp directory, or do you have limited space on the entire system partition? In other words, do you have sufficient space to install Qt and the rest?

    You have to install other items as well to get everything to work fine. I pulled those from Jessie...



  • [quote author="Jan-Willem" date="1407311806"]Is the insufficient space remark limited to the temp directory, or do you have limited space on the entire system partition?[/quote]

    Terabytes available, but just not on /tmp. There ought to be a way to tell the installer to use another place for temp storage, but I can't find anything about it. :(



  • The /tmp is cleared at boot I believe, so if there usually is plenty of room in /tmp, a fresh boot should be sufficient.

    For using another place for temp storage, you should look for a setting in Debian, not in the installer of Qt.

    Most simple solution however is to use the offline installer.



  • Take a look at this: http://www.linuxquestions.org/questions/linux-newbie-8/change-tmp-directory-774010/

    It's a bit old, but it might work. In short, as root:

    edit /etc/fstab so that /tmp points to the new location;

    chown root:root /tmp

    chmod 1777 /tmp



  • [quote author="Jan-Willem" date="1407314526"]The /tmp is cleared at boot I believe, so if there usually is plenty of room in /tmp ... [/quote]

    There isn't, though. It's 3% full, but it is only 350MB and the installer wants 700+MB.

    [quote author="Jan-Willem" date="1407314526"]For using another place for temp storage, you should look for a setting in Debian, not in the installer of Qt.[/quote]

    I was hoping the installer would use an environment variable like TMP to define the temp directory, but it doesn't appear to.



  • [quote author="Jan-Willem" date="1407315002"]Take a look at this: http://www.linuxquestions.org/questions/linux-newbie-8/change-tmp-directory-774010/[/quote]

    Yes, I can always plug in a USB drive I suppose and mount /tmp there. I was just looking for the easy answer! :)

    Many thanks for your help anyway.



  • Or you could remove the corresponding entry in /etc/fstab and reboot Debian. If I'm not mistaken, the /tmp will be placed on the root partition with Terabytes available. I have not tried something like that myself however. And you have probably an unused partition of 350 MB .

    And as already told, the easy answer is to use the offline installer.

    But you're welcome and good luck.



  • [quote author="Jan-Willem" date="1407320286"]... the easy answer is to use the offline installer.
    [/quote]

    Tried it, and eventually managed to get it to work. The trick seems to be to run it as root; if not, it just fails at random (different) places during the install. So now I have Qt5!



  • I've had this problem here. My /tmp was very small. So I setup an environment variable (TMPDIR I guess - I don't remember) pointing to another location.



  • Well, how silly of me. But ofcourse you have to install it as root.
    Although it seems like it might be installed in any directory of your choice, on my system it defaults to /opt.

    I never gave this a thought, since I always install apps as root. So it did not occur to me to hint this as a solution

    I'm glad you figured it out though.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.