Compile on windows, link fails at QtGuid4



  • Hello all!

    I tried to compile lgpl version of QT 4.7.2 on Windows with msvc2003 command line. Everything went fine, until nmake reached QtGuid4 linking. Error seems like this:

    @
    link /LIBPATH:"d:\qt-everywhere\lib" /LIBPATH:"d:\qt-everywhere\lib" /NOLOGO /BASE:0x65000000 /DEBUG /DLL /VERSION:4.72 /OUT:....\lib\QtG
    uid4.dll @C:\DOCUME~1\Ish\LOCALS~1\Temp\nm5DE.tmp
    Creating library ....\lib\QtGuid4.lib and object ....\lib\QtGuid4.exp
    qtextureglyphcache.obj : error LNK2019: unresolved external symbol "public: struct QFontEngineFT::Glyph * __thiscall QFontEngineFT::loadGlyph(struct QFontEngineFT::QGlyphSet *,unsigned int,enum QFontEngineFT::GlyphFormat,bool)const " (?loadGlyph@QFontEngineFT@@QBEPAUGlyph@1@PAUQGlyphSet@1@IW4GlyphFormat@1@_N@Z) referenced in function "public: struct QFontEngineFT::Glyph * __thiscall QFontEngineFT::loadGlyph(unsigned int,enum QFontEngineFT::GlyphFormat,bool)const " (?loadGlyph@QFontEngineFT@@QBEPAUGlyph@1@IW4GlyphFormat@1@_N@Z)
    ....\lib\QtGuid4.dll : fatal error LNK1120: 1 unresolved externals
    NMAKE : fatal error U1077: 'link' : return code '0x460'
    Stop.
    NMAKE : fatal error U1077: 'D:\MVCT2003\bin\nmake.exe' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.
    @

    If every object file was built before this point, and i haven't modified source and header files, what could be the problem?

    If it could help, I've used to configure with these parameters:

    @
    configure -platform win32-msvc2003 -qt-gif -qt-sql-odbc -qt-sql-sqlite -qt-sql-mysql -phonon -no-qt3support -stl -webkit
    -phonon-backend -plugin-sql-mysql -multimedia -audio-backend -plugin-sql-odbc -openssl -mmx -3dnow -sse -sse2 -dbus
    -shared -ltcg -dsp -no-vcproj -mp -qmake -qt-freetype -usedeffiles -no-s60
    @

    Thanks for any help and sorry for my bad english. :)



  • I'm not sure, but I would try configure to leave out FreeType (replace -qt-freetype with -no-freetype).



  • Problem solved, without FreeType it compiled successfully. Thank you for the advice! :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.