Toradex Apalis imx6 + Qt5.3.1 + X11 (Angstrom)

  • Hi,

    as there is the Qt Enterprise Boot2Qt Demo Image available for the Toradex imx6 without an X server, I wonder whether anybody succeeded in compiling Qt5.3.1 for X11 (xcb) at all or even with OpenGL support.

    I am using the Openembedded toolchain.

    I tried a lot of configure parameter configurations, but most tutorials are for use without X11.
    So I tried to configure with: -qpa xcb -no-eglfs -no-opengl -opengl es2
    -qpa xcb -no-eglfs -opengl es2
    -qpa xcb -no-eglfs -no-opengl

    full configure command looks like this: @./configure -qpa xcb -no-eglfs -no-opengl -opengl es2 -device imx6 -device-option CROSS_COMPILE=~/openembedded/oe-core/build/out-eglibc/sysroots/x86_64-linux/usr/bin/armv7ahf-vfp-neon-angstrom-linux-gnueabi/arm-angstrom-linux-gnueabi- -sysroot ~/openembedded/oe-core/build/out-eglibc/sysroots/apalis-imx6 -opensource -confirm-license -optimized-qmake -release -make tests -prefix /opt/qt5-imx6 -make examples -no-pch -qt-xcb -skip qttools -no-kms -fontconfig –v@ configure says that everything is fine, even OpenGL yes (ES 2.x).

    When I run make, everything looks fine, but after deployment I get the following segfault when running opengl-examples:
    @Qt Warning: Could not find a location of the system's compose files. consider setting the QTCOMPOSE environment variable.
    QXcbIntegration: Cannot create platform OpenGL context, neither GLX or EGL are enabled.
    Segmentation fault.@

    Maybe the problem is the included qt-xcb? When I try to configure Qt without qt-xcb I get the following error: @xcb-syslib disabled.
    The test for linking against libxcb and support libraries failed!
    You might need to install dependency packages, or pass -qt-xcb.@

    I also tried to build libxcb with openembedded, but it seems to me that it isn't available as a recipie.

    Adapting these instructions "Integrate Qt5 into yocto sato image (Wandboard)": for Qt5.3.1 also could not get me further towards a running Qt5 environment.

    Can anybody point me in the right direction, what else I could try?

    Thanks in advance,

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.