Qt World Summit: Register Today!

Can't route in bing maps with Qt WebView

  • I have a QWebView which displays the content of the page. When I go to http://www.bing.com/maps/ and want to give source/destination for routing and press the route button nothing is happened. The same thing I've tried with arora browser and got the same result. Is there somebody who knows what is the problem or it is a bug in Qt's webkit module.

  • Which platform did you try this on? This worked quite well for me with Qt 4.7b2 and on win xp

  • or probably post your code. did the webview work with other urls ?

  • It was really strange. I had tried yesterday evening and it was working but now it doesn't work anymore :(. I'm using Meego platform, the version of Qt is 4.6.2 (also can't determine the Webkit version QTWEBKIT_VERSION define is not present in this QT version as I can see). After having this issue I've created just a simple test to localize the issue. Here is the code:


    #include <QApplication>
    #include <QtWebKit>

    int main(int argc, char** argv)
    QApplication app(argc, argv);
    QWebView webview;
    webview.resize(900, 700);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::JavascriptEnabled, true);
    QWebSettings::globalSettings()->setAttribute(QWebSettings::JavaEnabled, true);
    return app.exec();

  • I think you should log a bug against meego. This code works just fine in win32 platform

  • QTWEBKIT_VERSION is only defined for QtWebKit 2.0 and above. Qt 4.6 have a dedicated branch of QtWebKit of that version.

    I think you should log a bug against meego.

    Which MeeGo are you using? MeeGo Netbook or Meego Handset?

    I have tried on Meego Netbook 1.0 with a custom build of Qt 4.7 and I cannot reproduce the bug.

  • Actually I used the QtWebkit came with Qt 4.6.2 When I upgraded my QtWebKit module (freshest trunk) it started to work. I'll not open a bug as it is already fixed in new versions.. :)

  • ok good its solved now :)

Log in to reply