HELP please : :-1: erreur : cannot find -lGL



  • Hello everybody,

    I've a problem compiling my Qt programs.
    Each time I try to compile I get this message : ":-1: erreur : cannot find -lGL"

    I'm running on a Linux Mint 16 (32bits)
    My compiler is a GCC 4.8.1

    I've downloaded this website's downloadable QtCreator 3.1.2 and installed it following the Linux's usual installation way. It ran without error.
    I got that message when I tried to compile my first program (Window with push button) .
    I've then tried to uninstall and reinstall QtCreator, just in case something was missing. It was useless.

    Can someone help me fixing this problem ?
    Thank a lot.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Please start by searching this forum, this question has been asked many times. You are missing the OpenGL development libraries



  • thanks a lot ;-)


  • Lifetime Qt Champion

    You're welcome !

    Now that you have it working, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.