Using MAR: git push ... fails with ssh: ... port 22 Bad file number



  • I tried to push some hello world example to the mar but i get the error message:

    ssh: connect to host git-mar-eu-1.qtc.io port 22: Bad file number

    I am using Windows 7. ssh keys should be installed correct.

    Does someone has an idea?

    Thanks in advance.


  • cid:52:privileges:purge

    This error usually means you were unable to connect to the server. Do you have some firewall, VPN or proxy that is blocking port 22?



  • Thank you for the information. It seems to be, that the proxy is causing the problem. I will setup a complete new computer without proxy.



  • I get the same error message but I don't have a possibility to avoid the use of proxy.

    I already tried:
    @git config --global http.proxy proxy:port
    git config --global https.proxy proxy:port@

    with the proxy and port as it is set in my firefox/IE, but the result is the same.

    I am no expert neigther in git nor in proxy. Did I miss anything or is there any known solution?

    Thanks in advance!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.