[SOLVED][5.3] "icuuc52.dll missing entry point" when deploying



  • Hello,

    I want to be able to send my project to a friend so I needed to get all the dynamic lib.

    Thought the best way was to use winqtdeploy.exe tool.

    The tool did his job, but when trying to run the binary, it just says there's a missing entry point for function "getAppendBuffer" in icuuc52.dll.

    I tried to get it directly from de icu project download page but I have the same error.

    The app runs just fine when runned through Qt Creator

    A screenshot of the windeployqt.exe and the error : http://puu.sh/9IKgj/19fa0fd6ef.png

    Thank you for your help !

    Aichan


  • Moderators

    Hi, that message usually means you took the wrong version of the DLL.

    How many copies of Qt did you install?

    Did you put anything Qt-related in your PATH? If so, remove them from your PATH. Then, try running windeployqt again.



  • Thank you for your reply

    1. I had Qt 5.2 installed but I uninstalled it and installed Qt 5.3 after

    2. Only thing related to Qt is C:\Qt\5.3\msvc2012_opengl\bin so I can use windeployqt.exe more easily, it's recommended in the documentation

    (Edit : ) Might be linked : I can't compile anymore, I probably changed something I should not have while trying to fix my dll issue, so now jom.exe returns a "Error code 2"

    (Edit 2 : ) It's fixed ! I used the maintenance tool, updated Qt modules and It looks like it has fixed it, I can now compile and deploy correctly !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.