[Solved] Compiling under Xubuntu 14.04: unjustified/puzzling linker-error



  • I am running Xubuntu 14.04 with Qt 5.3.0 (compiler is gcc or maybe g++) and I am trying to compile a program - it compiled (a while ago) under Kubuntu 12.10, it compiles under Windows 7, but I always get some errors under Xubuntu.

    @/usr/bin/ld: libpython3.4m.a(dynload_shlib.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
    //lib/x86_64-linux-gnu/libdl.so.2: error adding symbols: DSO missing from command line
    collect2: error: ld returned 1 exit status@

    I am using two self-compiled libraries - if I change the order they are handed over in within my .pro-file, the other one will throw a very similar error and stop the compilation instead.
    I already tried handing over libdl manually (which was not necessary before!), but that results in lots of "undefined references" and, at least by itself, is not a solution.

    I really don't know what to do - I would prefer developing under Xubuntu, but I am bound to use Windows right now. Does anybody have any ideas?

    EDIT: I missed a switch to make my self-compiled library a "shared object" (.so), so I tried using a static version instead, which caused this error. The error-message didn't help me out, though - I solved things by accident instead.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.